Dear visitor, welcome to cls-design Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

61

Tuesday, April 17th 2012, 7:45am

also wenn ich installieren will kommt die meldung

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Fatal error: PHP warning in file /www/htdocs/w00b2911/wbb3/wcf/lib/system/template/patch/TemplatePatch.class.php (367): copy(/www/htdocs/w00b2911/wbb3/wcf/../templates/thread.tpl) [<a href='function.copy'>function.copy</a>]: failed to open stream: Permission denied

Information:

error message: PHP warning in file /www/htdocs/w00b2911/wbb3/wcf/lib/system/template/patch/TemplatePatch.class.php (367): copy(/www/htdocs/w00b2911/wbb3/wcf/../templates/thread.tpl) [<a href='function.copy'>function.copy</a>]: failed to open stream: Permission denied
php version: 5.2.12-nmm2
wcf version: 1.1.8 (Tempest)
file: /www/htdocs/w00b2911/wbb3/wcf/lib/system/WCF.class.php (281)
error code: 0
date: 04/17/2012 05:43am
request: /acp/index.php?page=Package&step=TemplatePatchPackageInstallationPlugin&queueID=380&action=install&packageID=48&
referer: http://www.forentreff.eu/acp/index.php?page=Package&step=execPackageInstallationPlugins&queueID=380&action=install&packageID=48&
Stacktrace:

#0 /www/htdocs/w00b2911/wbb3/wcf/lib/system/template/patch/TemplatePatch.class.php(367): WCF::handleError(2, 'copy(/www/htdoc...', '/www/htdocs/w00...', 367, Array)
#1 /www/htdocs/w00b2911/wbb3/wcf/lib/system/template/patch/TemplatePatch.class.php(266): TemplatePatch->copyPatchedFile('/tmp/patchOutpu...', '/www/htdocs/w00...')
#2 /www/htdocs/w00b2911/wbb3/wcf/lib/system/template/patch/TemplatePatch.class.php(105): TemplatePatch->checkDiffType()
#3 /www/htdocs/w00b2911/wbb3/wcf/lib/acp/package/plugin/TemplatePatchPackageInstallationPlugin.class.php(54): TemplatePatch->__construct(0)
#4 /www/htdocs/w00b2911/wbb3/wcf/lib/acp/package/PackageInstallationQueue.class.php(146): TemplatePatchPackageInstallationPlugin->install('293', '--- /Users/admi...', false, false, 0, '', 2)
#5 /www/htdocs/w00b2911/wbb3/wcf/lib/acp/package/PackageInstallation.class.php(328): PackageInstallationQueue->executePackageInstallationPlugin()
#6 /www/htdocs/w00b2911/wbb3/wcf/lib/acp/package/PackageInstallation.class.php(52): PackageInstallation->install('TemplatePatchPa...')
#7 /www/htdocs/w00b2911/wbb3/wcf/lib/acp/page/PackagePage.class.php(49): PackageInstallation->__construct()
#8 /www/htdocs/w00b2911/wbb3/wcf/lib/page/AbstractPage.class.php(46): PackagePage->show(380)
#9 /www/htdocs/w00b2911/wbb3/wcf/lib/util/RequestHandler.class.php(64): AbstractPage->__construct()
#10 /www/htdocs/w00b2911/wbb3/wcf/lib/util/RequestHandler.class.php(92): RequestHandler->__construct()
#11 /www/htdocs/w00b2911/wbb3/acp/index.php(8): RequestHandler::handle('Package', Array, 'page')
#12 {main}

Click the button below to undo the installation that lead to this error and to clean up your system.

  • »Descole« is a Customer

Occupation: Schüler

  • Send private message

62

Tuesday, April 17th 2012, 3:19pm

Chmod Rechte 777?

63

Wednesday, April 18th 2012, 9:18am

jupp aber nun kommt

Source code

1
Beim Versuch die Dateien des Paketes zu entpacken, ist folgender Fehler aufgetreten: A non-standalone package can't overwrite template files. Only an update from the package which owns the template can do that. (Package 'com.cls-design.advertising' tries to overwrite template 'advertisingThreadsMessage', which is owned by package 'com.cls-design.advertising') (13026)

64

Wednesday, April 18th 2012, 10:06am

Schau mal ob das Paket trotz Abbruch nicht schon existiert, zumindest Teile davon liegen im System.
Die Definition von Wahnsinn ist, immer wieder das Gleiche zu tun und andere Ergebnisse zu erwarten…

65

Wednesday, April 18th 2012, 1:25pm

ja es ist installiert nun...komisch..naja mal testen ob es auch funktioniert

66

Thursday, April 19th 2012, 2:01pm

so wie es aussieht wurde es ja installiert...aber bestimmt nicht richtig...also werbung drinne..rechte gesetzt aber es wird nichts angezeigt in dem beiträgen

  • »Descole« is a Customer

Occupation: Schüler

  • Send private message

67

Thursday, April 19th 2012, 5:05pm

Ich kenne das Plugin zwar nicht, aber schaue selber mal nach ob das Plugin überhaupt aktiviert ist,
bei wem du alles die Rechte verteilt hast,

68

Monday, April 23rd 2012, 2:28pm

Schau mal in der thread.tpl Datei in der Line 246 - Wenn da der {/if} Tag vorhanden ist entferne ihn
-> Wichtig! Mach vorerst ein Backup von der thread.tpl. <-

Sonstig options.inc.php neugenerieren lassen und cache im wcf/templates/compiled leeren.
Muss aber daran liegen, dass der Patch nicht richtig entfernt wurde.
den {/if} habe ich ja entfernt. und alles ging.
nehme ich aber Änderungen im template vor, wird das template ja kopiert.

Im standard template ist aber der Fehler noch vorhanden. wie kann ich denn das template ändern, ohne das es kopiert wird?
also das Template in der Kategorie standardtemplate ändern?

Ich hoffe ihr versteht was ich meine.

  • »Descole« is a Customer

Occupation: Schüler

  • Send private message

69

Monday, April 23rd 2012, 3:30pm

Über FTP (Filezilla).
unter wbb/wcf/templates

70

Tuesday, May 29th 2012, 7:35pm

Ich habe das Teil installiert, es kommt auch kein Fehler, aber ich kann in den Gruppen nichts aktivieren, damit es funktioniert ?



Ich habe mal in die Sprachvariablen geschaut, der legt die garnicht an

Gruß bobo

This post has been edited 1 times, last edit by "ruhrpottbobo" (May 29th 2012, 8:20pm)


  • »Cetheus« is a Customer

Location: Wolfsburg

Occupation: Programmierer

  • Send private message

71

Wednesday, May 30th 2012, 1:18am

Hmm welche Sprache nutzt du?
Dem Paket liegt Deutsch und Deutsch Du bei...
MfG Cetheus
Visit us @Konsolengrill.de

72

Wednesday, May 30th 2012, 7:28am

Ich habe deutsch klar, ich verstehe es einfach nicht :(
Gruß bobo


73

Friday, June 8th 2012, 12:10am

Eine Frage: Ich hätte im ACP mal die Werbung für Admins deaktiviert. Wird aber trotzdem angezeigt.
Was muss ich denn machen, damit die Werbung für Admins raus ist?

74

Friday, June 8th 2012, 1:55pm

Benutzergruppe Jeder auch bearbeitet?

75

Friday, June 8th 2012, 4:37pm

Danke, dass war der Fehler!

Wenn ein Benutzer in mehreren Gruppen ist, muss man alle Gruppen bearbeiten, in der er ist. Eigentlich logisch. Funktioniert jetzt perfekt, vielen Dank nochmals.

l.g.
wbartl

76

Friday, June 8th 2012, 4:39pm

Das Vergisst man schnell so was ;)

77

Sunday, July 22nd 2012, 11:00pm

Hey,

Ich habe ein Problem was die Gruppenrechte angeht.
Ich habe es so eingestellt das nur Gäste die komplette Werbung sehen können (Im ersten beitrag in themen usw...).
Doch leider klappt es nicht? Auch registrierte benutzer und meine Premium nutzer können die Werbung problemlos sehen was nicht der fall sein sollte.

ja die Gruppe Jeder wurde beachtet.
Mit freundlichen Grüßen

Bünyamin Sel


PressHosting.de Webspace mit Maximaler Power zu einem Gedrücktem Preis!

GamerFuture.de Gamer helfen Gamer!

78

Monday, July 23rd 2012, 8:38am

Ich verstehe einfach nicht waum der bei mir die Gruppenrechte nicht korrekt zeigt ;(
so sieht es aus



Ist das überhauot die aktuellste Version ?
Von RC1 steht das nichts.



Kann es sein dass das hier irgendwie fehlt bei mir ?

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
<?xml version="1.0"?>
<data xmlns="http://www.woltlab.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.woltlab.com/XSD/pagelocation.xsd">
	<import>
		<categories>
			<category name="user.board.threadAdvertising">
				<parent>user.board</parent>
			</category>
		</categories>
		<options>
			<option name="user.advertising.thread.top.canView">
				<categoryname>user.board.threadAdvertising</categoryname>
				<optiontype>boolean</optiontype>
				<defaultvalue>1</defaultvalue>
			</option>
			<option name="user.advertising.thread.message.canView">
				<categoryname>user.board.threadAdvertising</categoryname>
				<optiontype>boolean</optiontype>
				<defaultvalue>1</defaultvalue>
			</option>
			<option name="user.advertising.thread.messages.canView">
				<categoryname>user.board.threadAdvertising</categoryname>
				<optiontype>boolean</optiontype>
				<defaultvalue>1</defaultvalue>
			</option>
			<option name="user.advertising.thread.bottom.canView">
				<categoryname>user.board.threadAdvertising</categoryname>
				<optiontype>boolean</optiontype>
				<defaultvalue>1</defaultvalue>
			</option>
		</options>
	</import>
</data>
Gruß bobo

This post has been edited 2 times, last edit by "ruhrpottbobo" (Jul 23rd 2012, 9:30am)


79

Monday, July 23rd 2012, 10:16am

Ich hab das Paket im ersten Beitrag geändert:

Adsenseintgration in Themen

Jetzt sollte es einfacher sein die Rechte einzustellen da alle von Anfang an deaktiviert sind. Bitte das Paket deinstallieren und das neue installieren.
Die Definition von Wahnsinn ist, immer wieder das Gleiche zu tun und andere Ergebnisse zu erwarten…

80

Monday, July 23rd 2012, 11:42am

geht immer noch nicht, schade, er zeigt einfach die Anzeige der Gruppenrechte nicht an um diese zu aktivieren oder deaktivieren ;(
Gruß bobo


Similar threads

You are not logged in.

Login - Register