WS 3.0 Teaser

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Moin habe auch noch kurz eine Frage.

      Wo muss ich diese 2 Codes einfügen?

      Quellcode

      1. <div class="slider-container-wrapper {if TEASERS_POSITION == content || TEASERS_POSITION == belowcontent}marginTop{/if}">
      2. {if TEASER_FULLSIZE == 1 && TEASERS_POSITION == header}<div class="layoutBoundary">{/if}
      3. <div class="slider-container">
      4. {include file='pageHeaderLogo'}
      5. <div class="slider">


      Quellcode

      1. .pageHeaderLogo {
      2. position: absolute;
      3. top: 20px;
      4. left: 20px;
      5. z-index: 100;
      6. }
    • Tom schrieb:

      Ja, aber du kannst ihn ja so lange deinstallieren, du verlierst ja keine Daten. Ich denke ich werde den sowieso komplett umschreiben und in eine Box setzen, da wird dann eh kein Update möglich sein da man da auch die Templatelistener entfernen müsste usw. Das ist mir zu aufwendig zu testen.

      Ja, das war's dann mit dem Vorhaben direkt mit der neuen Version vom Core etc. neu zu starten. Was soll das denn heißen "Ja, aber du kannst ihn ja so lange deinstallieren, du verlierst ja keine Daten." - Das Plugin steht mir ja dann nicht zur Verfügung und an Stellen wo das Plugin eingesetzt wurden fehlen mir ja die Bilder zum Beispiel. Also dieser Satz ist "etwas" schief gegangen, denke ich. ;)
      proSidor - Wir haben die aktuellen Nachrichten der WoltLab-Szene!
    • Verstehe ich jetzt nicht ganz?

      Perikles schrieb:

      Das Plugin steht mir ja dann nicht zur Verfügung…
      Ja jetzt, aber in ein paar Tagen gibt es dann auch eine neue Version die in 3.0 und 3.1 läuft.

      Es wird von der aktuellen Beta 2 kein Update geben. Jeder der ein Update auf 3.1 machen will, der muss die Version Beta 2 deinstallieren und die Beta 3 neu installieren. Es hat sich zu viel geändert und mir ist das Testen der Updates einfach zu aufwendig da man ja die kostenlosen Plugins auch alle kurz neu installieren kann.
      TwitterFacebook

      Mein Blog: TwentyMag <- Lesen, Teilen, Liken, Kommentieren, Abonnieren. Ihr wisst bescheid, was labere ich hier groß rum
      :eyes:
    • Das geht nur an der Position "Hero" (oder die Position darunter) und wenn die Option "Auf die Seitenbreite begrenzen" nicht aktiv ist. Ansonsten wäre es sinnvoller den Slider per Templateänderung einzubinden und dann eben manuell im Stil einzubauen.
      TwitterFacebook

      Mein Blog: TwentyMag <- Lesen, Teilen, Liken, Kommentieren, Abonnieren. Ihr wisst bescheid, was labere ich hier groß rum
      :eyes:
    • Hi,


      ich habe gerade die Beta 2 deinstalliert und dann die Beta 3 installiert. Es handelt sich hierbei um ein Kundenprojekt.
      Dabei wird folgender Fatal Error geworfen, der auch nach der Deinstallation der Beta 3 bestehen bleibt.


      Quellcode

      1. Sun, 18 Feb 2018 17:36:21 +0000
      2. Message: Use of undefined constant TEASER_SHOW - assumed 'TEASER_SHOW'
      3. PHP version: 7.0.25-nmm1
      4. WoltLab Suite version: 3.0.12 pl 1
      5. Request URI: /
      6. Referrer:
      7. User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6
      8. Peak Memory Usage: 10372224/134217728
      9. ======
      10. Error Class: wcf\system\exception\ErrorException
      11. Error Message: Use of undefined constant TEASER_SHOW - assumed 'TEASER_SHOW'
      12. Error Code: 0
      13. File: /www/htdocs/w012cc9b/f1-gaming-community/lib/system/WCF.class.php (313)
      14. Extra Information: -
      15. Stack Trace: [{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/templates\/compiled\/2_wcf_1_cms.php","line":940,"function":"handleError","class":"wcf\\system\\WCF","type":"::","args":[8,"Use of undefined constant TEASER_SHOW - assumed 'TEASER_SHOW'","\/www\/htdocs\/w012cc9b\/f1-gaming-community\/templates\/compiled\/2_wcf_1_cms.php",940,{"templateName":"[redacted]","application":"[redacted]","sendHeaders":"[redacted]","this":"[redacted]","sourceFilename":"[redacted]","compiledFilename":"[redacted]","metaDataFilename":"[redacted]","metaData":"[redacted]","_lengthe9085febb3beca46b9d106bd313c37075c30f3ca":"[redacted]","_ie9085febb3beca46b9d106bd313c37075c30f3ca":"[redacted]","_foreach_3f3c084db1999d203605b6ed2039f1e4f23f5bb6":"[redacted]","_foreach_3f3c084db1999d203605b6ed2039f1e4f23f5bb6_cnt":"[redacted]","__langCompilerTemplatePluginOutput":"[redacted]"}]},{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/lib\/system\/template\/TemplateEngine.class.php","line":320,"args":["\/www\/htdocs\/w012cc9b\/f1-gaming-community\/templates\/compiled\/2_wcf_1_cms.php"],"function":"include","class":"","type":""},{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/lib\/page\/AbstractPage.class.php","line":308,"function":"display","class":"wcf\\system\\template\\TemplateEngine","type":"->","args":["cms","wcf"]},{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/lib\/page\/AbstractPage.class.php","line":103,"function":"show","class":"wcf\\page\\AbstractPage","type":"->","args":[]},{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/lib\/system\/request\/Request.class.php","line":83,"function":"__run","class":"wcf\\page\\AbstractPage","type":"->","args":[]},{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/lib\/system\/request\/RequestHandler.class.php","line":94,"function":"execute","class":"wcf\\system\\request\\Request","type":"->","args":[]},{"file":"\/www\/htdocs\/w012cc9b\/f1-gaming-community\/index.php","line":9,"function":"handle","class":"wcf\\system\\request\\RequestHandler","type":"->","args":["wcf"]}]
      Alles anzeigen
      Den Systemcache habe ich bereist erfolglos gelöscht. Backups sind vorhanden, die ich zurückspielen kann, jedoch wäre es trotzdem gut, wenn der Fehler behoben wird.
    • Die Fehlermeldung zeigt an das im Template:

      templates/compiled/2_wcf_1_cms.php

      eine Konstante aufgerufen wird die nicht mehr existiert. TEASER_SHOW stammt übrigens aus Beta 2, in Beta 3 ist die nicht mehr enthalten.

      Ich würde eher darauf tippen das die Deinstallation der Beta 2 fehlgeschlagen ist da das System noch ein Include versucht. Am besten schaust du mal ob in der Datenbank die Evenlistener vom Teaser noch drin sind.
      TwitterFacebook

      Mein Blog: TwentyMag <- Lesen, Teilen, Liken, Kommentieren, Abonnieren. Ihr wisst bescheid, was labere ich hier groß rum
      :eyes:
    • Was das aktuelle Problem anbelangt; (jacboy hat meinen Kunden übernommen, da ich die letzte Zeit zu beschäftigt war und leider verhindert war)

      Für diese Community hatte ich per Anleitung von Seite 3 den Teaser im Header eingebunden.
      Doch durch das Update war ich jetzt gezwungen alles zu deinstallieren und neu aufzusetzen.
      Also habe ich Beta 3 auf der aktuellen RC4 installiert.


      So, also habe ich den Nero Stil installiert und den Teaser per

      Quellcode

      1. {include file='__teaser'}
      eingebunden.


      Doch jetzt meckert die Suite rum, das es das Template "teaser" nicht gibt.
      Das ist soweit verständlich.


      Doch wenn ich __teaser kopieren möchte, findet er nichts in den Standardtemplates.
      Habe ich was übersehen oder hat sich was geändert?

      Ziel ist es, den Teaser im Header einzufügen, was ja bei 3.0 erfolgreich geklappt hat.

      PS: Wenn ich den Teaser per Box integriere, zum Beispiel am "Seitenende", funktioniert das.
      Bilder
      • Manuell über die Templates.png

        91,78 kB, 676×521, 18 mal angesehen
      • Standardeinbindung über das Boxensystem.png

        973,07 kB, 1.395×566, 19 mal angesehen
      =)

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von s. Oliver ()

    • WS 3.0 Teaser Box verkleinern + kein Text in Mobilansicht

      Moin zusammen!

      Was das programmieren angeht bin ich noch sehr unbeholfen....:)

      Ich habe 2 Probleme mit der Teaserbox im WSC 3.1

      1. Die Smartphone und tablet ansicht ist super aber am PC wird die box sehr groß, vor allem in der höhe angezeigt. Ich babe in einem thread zwar css codes gefunden mit der man das anpassen sollen kan, aber ich weiß nicht wo ich das einbinden soll.
      Ich habe das template boxteaser kopiert und dem stil zugeordnet, sodass ich es bearbeiten kann, weiter komme ich da a er nicht :)
      2. Bei der smartphone ansicht wird der text nicht angezeigt den ich im acp bei dem bild eingetragen habe. Ist das gewollt oder ein fehler?

      LG
      Necrar
    • okay danke. Das mit dem Text verstehe ich. Aber das mit dem Bild haut nicht hin. Hab die in 500x200 in den webspace geladen. Und wenn ich die seite öffne, dann sehe ich kurz wie sie klein/original sind. Und dann macht er sie auf die boxgröße groß, wodurch die Bilder auch unscharf werden. Hab das feld auf content größe einschränken auch in beiden Varianten ausprobiert, aber hilft nicht.