Mit WBB 3.1.8 bei Google auf den ersten 2 Seiten, mit WSC 5.1. überhaupt nicht mehr in Google

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Mit WBB 3.1.8 bei Google auf den ersten 2 Seiten, mit WSC 5.1. überhaupt nicht mehr in Google

      Wie kommt sowas?
      Ich habe ein kleines Forum, mit dem waren wir seit 2010 ziemlich gut gelistet bei Google, auf den ersten 2 Seiten auf jeden Fall.
      Mal auf Seite 1, dann mal auf 2, immer mal wechselnd.
      Das war WBB 3.1.8 ohne jeden Zirkus, keine Robots.txt ,keine Sitemap.Ich habe es 2010 bei Google eingetragen und es lief so vor sich hin.
      Mehr wollte ich auch nicht.
      Jetzt kommen wir mit dem neuen 5.1 überhaupt nicht mehr vor bei Google, null, nada.
      Bing hat uns auf Seite 2 oben, Yahoo hat uns auf etwa gleicher Position. Wechselt natürlich manchmal, aber was hat Google plötzlich gegen uns?
      Das neue 5.1 haben wir seit Anfang März 2018 in Betrieb, ich habe sogar eine Robots.txt erstellt, eine Sitemap ebenfalls, nützt nichts.
      Google kennt uns nicht mehr.
      Wie kommt das, was passt Google nicht? Googlebots sind neben den anderen auch dauernd da, nur existieren wir bei google nicht mehr.
      Wir sind seit 2011 bei dmoz gelistet.
      Ich werde jetzt erstmal die Robots.txt löschen und die Sitemap, hatten wir bei dem WBB 3.1.8 nicht und war super gelistet.
      Wenn das auch nicht funktioniert, installiere ich wieder WBB 3.1.8.
      Wir sind noch auf dem gleichen vServer, wie mit dem 3.1.8, kann also nicht an einem Serverwechsel liegen.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Phobi ()

    • Hast du die Indizierung von Google erlaubt ? Schau mal im ACP unter Seiten, dort muss für jede Seite die Du indiziert haben möchtest auch ein Häckchen gesetzt werden.

      Oder ihr wurdet abgestraft von Google, könnte auch sein.
      Oder Oder... kann viele Gründe dafür geben.Forenrechte der Themen/Beiträge etc.
    • Ja natürlich habe ich alle Seiten die indiziert werden sollen auch freigegeben mit Haken.

      Hatte mich ja vorher schon eingelesen in die neue Version 5.1. Etwa 1 Jahr Vorbereitung, wofür abgestraft?

      In der Robots.txt und Sitemap sind die Seiten aufgeführt die Google indizieren kann, nicht die wo Suchmaschinen nichts verloren haben.

      Am Anfang hatte ich mal im April 593 Suchmaschinenroboter online, die sich vor Robots Txt und Sitemap mit Kalender rumgeplagt haben, wo absolut nichts drinsteht.

      Ausser Geburtstage, danach habe ich Robots.txt und Sitemap verwndet.

      Ich habe keine Ahnung was Google nicht passt und auch Google Webmastertools liefern keine Erklärung.

      Da wird eine Seite aufgeführt die auch nicht durchsuchbar ist und sein soll, ist intern. Geht Google nichts an, Gäste bekommen bei uns üblicherweise die ersten 6 oder 8 Beiträge eines Themas zu lesen, danach müssen sie sich registrieren.

      War bei WBB 3.1.8 auch so und hat Google nicht gestört.

      Wir haben nichts geändert zwischen 3.18 und WSC 5.1 und trotzdem läuft es nicht mehr.
    • Nein ich habe diese. Mein Forum ist ja nicht im Ordner "Forum", sondern im Hauptverzeichnis.
      Ich habe ja auch nur Forum und Galerie von Woltlab. Da brauche ich ja keine Anweisungen für Blog und den anderen Kram.
      So sieht die jetzige aus.
      <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteBase /
      # Rewrite application /blog/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^blog/(.*)$ blog/index.php?$1 [L,QSA]
      # Rewrite application /calendar/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^wcf/calendar/(.*)$ wcf/calendar/index.php?$1 [L,QSA]
      # Rewrite application /gallery/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^wcf/gallery/(.*)$ wcf/gallery/index.php?$1 [L,QSA]
      # Rewrite application /filebase/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^filebase/(.*)$ filebase/index.php?$1 [L,QSA]
      # Rewrite application /forum/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^forum/(.*)$ forum/index.php?$1 [L,QSA]
      # Rewrite application /wcf/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^wcf/(.*)$ wcf/index.php?$1 [L,QSA]
      # Rewrite application /cms/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^cms/(.*)$ cms/index.php?$1 [L,QSA]
      # Rewrite application /core/
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^core/(.*)$ core/index.php?$1 [L,QSA]
      # Rewrite application /
      RewriteCond %{SCRIPT_FILENAME} !-d
      RewriteCond %{SCRIPT_FILENAME} !-f
      RewriteRule ^(.*)$ index.php?$1 [L,QSA]
      </IfModule>

      Dann müßte ich nach der neuen ja was ändern, die aus deinem Link
      # {PARENT_BOARDS}{BOARD_TITLE}/{THREAD_ID}-{THREAD_TOPIC}/last-post.html
      Alt: RewriteRule ^([^/\.]+/)*([^/\.]+)/([0-9]+)\-([^/\.]*)/last\-post\.html$ index.php?page=Thread&threadID=$3&action=lastPost [L,QSA]
      Neu: RewriteRule ^([^/\.]+/)*([^/\.]+)/([0-9]+)\-([^/\.]*)/last\-post\.html$ /forum/index.php?thread/$3-$4/&action=lastPost [R=301,QSA,L]

      In der neuen Rewrite Rule müsste dann das /forum weg? Weil es liegt ja im hauptverzeichnis. Also geht e gleich mit /index.php los?
      Wenn ich das Forum aufrufe und in irgendeinen Beitrag gehe dann sieht das so aus.
      board/3-domain-de-informationen/

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Phobi ()

    • Natürlich brauchst du von Burning Board 3.1 auf WoltLab Suite 3 Umleitungen, die Linkstruktur ist ja vollkommen anders. Deswegen stellt WoltLab die Umleitungen auch zu Verfügung. Das was du drin hast ist lediglich Kosmetik und entfernt das index aus der URL, das kann man auch genau so gut weglassen, ist nur Schnickschnack. Aber damit auch alle alte Links bei Google usw. erhalten bleiben mußt du die Umleitungen aus meinem Link entsprechend einfügen.

      Ist ja kein Wunder das du aus dem Index fliegst wenn alle Links nur noch einen Fehler zurück geben.
      TwitterFacebook

      Mein Blog: TwentyMag <- Lesen, Teilen, Liken, Kommentieren, Abonnieren. Ihr wisst bescheid, was labere ich hier groß rum
      :eyes:
    • Ich bin jetzt auch kein Fachmann, aber ich denke du mußt nur das /forum/ weglassen:

      Quellcode

      1. RewriteCond %{QUERY_STRING} page=User&userID=([0-9]+)
      2. RewriteRule ^index\.php$ index.php?user/%1/ [R=301,L]
      3. RewriteCond %{QUERY_STRING} page=Thread&threadID=([0-9]+)&action=lastPost
      4. RewriteRule ^index\.php$ index.php?thread/%1/&action=lastPost [R=301,L]
      5. RewriteCond %{QUERY_STRING} page=Thread&threadID=([0-9]+)&action=firstNew
      6. RewriteRule ^index\.php$ index.php?thread/%1/&action=firstNew [R=301,L]
      7. RewriteCond %{QUERY_STRING} page=Thread&postID=([0-9]+)
      8. RewriteRule ^index\.php$ index.php?thread/thread/&postID=%1#post%1 [NE,R=301,L]
      9. RewriteCond %{QUERY_STRING} page=Thread&postID=([0-9]+)#post([0-9]+)
      10. RewriteRule ^index\.php$ index.php?thread/thread/&postID=%1#post%1 [NE,R=301,L]
      11. RewriteCond %{QUERY_STRING} page=Thread&threadID=([0-9]+)&pageNo=([0-9]+)
      12. RewriteRule ^index\.php$ index.php?thread/%1/&pageNo=%2 [R=301,L]
      13. RewriteCond %{QUERY_STRING} page=Thread&threadID=([0-9]+)
      14. RewriteRule ^index\.php$ index.php?thread/%1/ [R=301,L]
      15. RewriteCond %{QUERY_STRING} page=Board&boardID=([0-9]+)&pageNo=([0-9]+)
      16. RewriteRule ^index\.php$ index.php?board/%1/&pageNo=%2 [R=301,L]
      17. RewriteCond %{QUERY_STRING} page=Board&boardID=([0-9]+)
      18. RewriteRule ^index\.php$ index.php?board/%1/ [R=301,L]
      19. RewriteCond %{QUERY_STRING} page=Attachment&attachmentID=([0-9]+)
      20. RewriteRule ^index\.php$ index.php?attachment/%1/ [R=301,L]
      21. RewriteCond %{QUERY_STRING} page=Index
      22. RewriteRule ^index\.php$ index.php?board-list/ [R=301,L]
      23. RewriteCond %{QUERY_STRING} page=Portal
      24. RewriteRule ^index\.php$ index.php?dashboard/ [R=301,L]
      Alles anzeigen
      und das vor deine Umschreibungen packen so das erst der Link korrigiert und dann das index entfernt wird.

      Beim Galerieteil bin ich aber überfragt.
      TwitterFacebook

      Mein Blog: TwentyMag <- Lesen, Teilen, Liken, Kommentieren, Abonnieren. Ihr wisst bescheid, was labere ich hier groß rum
      :eyes:
    • Hmm, in der Zeit sollten die neuen Seiten aber schon in Google zu finden sein. Ich dachte das wäre ein neuer Import. Hast du einen Google Webmaster Account? Vielleicht dort einfach direkt noch mal die Indexierung starten.
      TwitterFacebook

      Mein Blog: TwentyMag <- Lesen, Teilen, Liken, Kommentieren, Abonnieren. Ihr wisst bescheid, was labere ich hier groß rum
      :eyes:
    • Na ja Google ist ja dauernd da, ich glaube nicht das es an zuwenig Googlebesuchen liegt. Ist praktisch rund um die Uhr von Google wer da.
      Ich habe so einen Google Webmaster und schon zigmal neugestartet.
      Ist dann wohl nicht zu ändern.
      Mitte April waren sogar mal knapp 600 auf einmal da. Keine Ahnung von welcher Firma, Ahrefs und BlexBot sind ja auch dauernd da.
    • Ich kann mit dem Ding nur wenig anfangen, kann kein Englisch. Habe ich irgendwann mal eingerichtet aber nie wirklich genutzt.
      Das steht da, aber wir haben alle richtige PCs und keine Smartphones.
      "Googlebot for smartphones found an increase in authorization permission errors on https"
      Dasist alles, letzter Eintrag vom 28.4..
      Insgesamt 8 Einträge davon vom Anfang April an.
      Dann gibts noch das hier.

      URL Errors

      3 Server error
      9,662 Access denied

      62 Soft 404
      2,008 Not found

      Access denied ist 8000mal der Kalender, da hat weder Gäste noch Jeder Zugriff. Ist beabsichtigt so, der verdammte Kalender geht keinen was an, die Galerie darf nur von Leuten gesehen werden die in aktive Registrierte sind, also mindestens 25 Beiträge haben.
      Gleiches gilt für den SmallTalk Bereich, da hat auch erst jemand Zutritt wenn er mindestens 25 Beiträge verfasst hat im richtigen Teil des Forums.
      Auf der ersten Sitemap waren 8 GB Daten nur voll mit diesem Kalendermist.
      Nicht die Sitemap die im Forum eingebaut ist,die erstellt gar nichts. Ich habe mir A1 Sitemap Generator geholt, der zweite Versuch war dann nur nch ein paar hundert MB groß, ohne Kalender.
      Wir brauchen diesen Mistkalender gar nicht, wann Weihnachten oder Ostern ist steht in der Fernsehzeitung.
      Also was der bemängelt, da hat er sowieso nichts zu suchen, letzte Meldung 28.4.
      When we tested a sample of the URLs from your Sitemap, we found that some URLs were not accessible to Googlebot due to an HTTP status error. All accessible URLs will still be submitted.

      danach habe ich eine neue Robots.txt. gemacht, so wie ich es irgendwo im Internet gefunden habe.
      "
      User-agent: *


      Disallow: /domain.de/wcf/calendar/


      Disallow: /domain.de/wcf/gallery/


      Disallow: /domain.de/wcf/legal-notice/


      Disallow: /domain.de/wcf/contact/


      Disallow: /domain.de/wcf/datenschutzerklaerung/


      Disallow: /domain.de/wcf/sc-terms-of-use/

      Die scheint in Ordnung zu sein, 0 Errors 0 Warnings

      Bei der Sitemap steht, This Sitemap is pending.
      Ich find die ist ganz in Ordnung. Die aktuellste Version ist nicht so groß, nur ein paar KB.
      Wenn es die nicht will, ne andere gibt es nicht.
      Bei 3.1.8 hatte ich weder Robots text noch ne Sitemap oder irgend so ein Zeug und es hat wunderbar funktioniert.
      Dieser ganze moderne Mist ist Mist, wird immer teurer, taugt immer weniger.