Endanwendung Sprachproblem

    Endanwendung Sprachproblem

    Hallo,

    ich hab ein Endanwendungssystem gebastelt nun habe ich aber das Problem das wenn ich mit Sprachvariabeln arbeite das ich diese nicht im ACP bearbeiten kann da es in der Endanwendung kein Sprachmenüpunkt gibt. Also was habe ich gemacht? Ich habe den Text in die TPL eingebunden. Ich weiß das ist eigentlich eine Tod Sünde aber ich muss halt nun mal die Texte auch überarbeiten / bearbeiten können.

    Nun ist es aber so, das in den ganzen Texten keine Ü Ä etc. angezeigt werden und das natürlich etwas nervig wird das ganz immer mit diesem HTML Schreibweisen einzubauen ist meine Frage, kann ich das so machen das die Texte in den TPLs auch richtig dargestellt werden mit Ä,Ö,Ü usw. ?

    oder kann ich irgendwie bei der Endanwendung das so machen das dort der Menüpunkt für die Sprachen hinzugefügt wird?

    PS: Die Texte werden auch in den TPLs verwendet die ich als Includes benutze. Sprich ich binde z.b. nur texte ein die in Includes stehen so kann es also sein das in der TPL eine Inculde verzeichnet ist und in dieser include nur ein Text steht.
    Nimm das Leben nicht so ernst, du kommst hier eh nicht lebend raus!

    LiberrY wrote:

    Ich weiß das ist eigentlich eine Tod Sünde aber ich muss halt nun mal die Texte auch überarbeiten / bearbeiten können.

    Du solltest deine Texte eh in XML-dateien mitliefern. Änder die Sprachvariablen einfach in den XMl-dateien und re-installier die EA. Als Entwickler braucht man die Sprachverwaltung im ACo schlichtweg nicht. man schreibt die Sprachvariablen in die Sprachdateien, und gut ist. Wenn du etwas n den XMl dateien änderst und willst die Änderungen sofort live sehen, kannst du natürlich auch direkt die datenbankeinträge ändern.

    LiberrY wrote:

    Nun ist es aber so, das in den ganzen Texten keine Ü Ä etc. angezeigt werden und das natürlich etwas nervig wird das ganz immer mit diesem HTML Schreibweisen einzubauen ist meine Frage, kann ich das so machen das die Texte in den TPLs auch richtig dargestellt werden mit Ä,Ö,Ü usw. ?

    Wenn du das direkt ins Template einbaust, musst du Sonderzeichen selbstverständlich als HTMl Entities schreiben. Das ist technisch bedingt. das WCF führt diese Umwandlung in Sprachvariablen selber implizit durch.

    LiberrY wrote:

    oder kann ich irgendwie bei der Endanwendung das so machen das dort der Menüpunkt für die Sprachen hinzugefügt wird?

    Du kannst dir ein Plugin für deine EA schreiben, dass die Sprachverwaltung als abhängigkeit hat, dann wird diese auch im ACP deiner EA angezeigt.