Error bei Installation der Lizenzseite

  • Hallo Jungs, erstmal klasse das es euch und eure Plugins, Stile, etc. gibt. Nun habe ich gerade das "Lizenzseite Plugin" installieren wollen, und es gab jedoch leider ein Problem.




    Bei 88% bekamm ich diesen Fehler


    Quote

    Fatal error: PHP warning in file /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/package/PackageInstallationQueue.class.php (509): file_exists() [<a href='function.file-exists'>function.file-exists</a>]: open_basedir restriction in effect. File(/var/www/vhosts/der-ls-treffpunkt.de/options.inc.php) is not within the allowed path(s): (/var/www/vhosts/der-ls-treffpunkt.de/httpdocs/:/tmp/:/var/www/vhosts/der-ls-treffpunkt.de/httpsdocs/:/tmp/)



    Information:
    error message: PHP warning in file /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/package/PackageInstallationQueue.class.php (509): file_exists() [<a href='function.file-exists'>function.file-exists</a>]: open_basedir restriction in effect. File(/var/www/vhosts/der-ls-treffpunkt.de/options.inc.php) is not within the allowed path(s): (/var/www/vhosts/der-ls-treffpunkt.de/httpdocs/:/tmp/:/var/www/vhosts/der-ls-treffpunkt.de/httpsdocs/:/tmp/)
    php version: 5.2.6-1+lenny16
    wcf version: 1.1.9 (Tempest)
    file: /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/system/WCF.class.php (281)
    error code: 0
    date: 10/17/2012 08:16pm
    request: /acp/index.php?page=Package&step=finish&queueID=272&action=install&packageID=48&
    referer: http://www.der-ls-treffpunkt.d…ion=install&packageID=48&


    Stacktrace:
    #0 [internal function]: WCF::handleError(2, 'file_exists() [...', '/var/www/vhosts...', 509, Array)
    #1 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/package/PackageInstallationQueue.class.php(509): file_exists('/var/www/vhosts...')
    #2 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/package/PackageInstallation.class.php(364): PackageInstallationQueue->makeClear()
    #3 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/package/PackageInstallation.class.php(300): PackageInstallation->finishInstallation()
    #4 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/package/PackageInstallation.class.php(52): PackageInstallation->install()
    #5 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/acp/page/PackagePage.class.php(49): PackageInstallation->__construct(272)
    #6 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/page/AbstractPage.class.php(46): PackagePage->show()
    #7 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/util/RequestHandler.class.php(64): AbstractPage->__construct()
    #8 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/wbb/lib/util/RequestHandler.class.php(92): RequestHandler->__construct('Package', Array, 'page')
    #9 /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/acp/index.php(8): RequestHandler::handle(Array)
    #10 {main}
    Click the button below to undo the installation that lead to this error and to clean up your system.


    Was bzw. woran kann das liegen?


    lg Mario

  • Der Pfad "/var/www/vhosts/der-ls-treffpunkt.de/options.inc.php" ist nicht in der "Erlaubten-Liste":

    • /var/www/vhosts/der-ls-treffpunkt.de/httpdocs/
    • /tmp/:/var/www/vhosts/der-ls-treffpunkt.de/httpsdocs/
    • /tmp/

    Eigentlich müsste es dann "/var/www/vhosts/der-ls-treffpunkt.de/httpdocs/options.inc.php" und/oder "/tmp/:/var/www/vhosts/der-ls-treffpunkt.de/httpsdocs/options.inc.php" sein.

  • Am besten mal beim provider nachfragen, wieso der gleiche Inhalt in zwei verschiedene Ordner muss bzw. warum man nicht in den ROOT-Ordner ("/var/www/vhosts/der-ls-treffpunkt.de/") schreiben kann (bzw. darum bitten, diese zur "Erlaubten-Liste" hinzuzufügen).


    Vermutlich läuft dein Forum im ROOT-Ordner, weshalb es komisch anmutet, wieso darin jetzt nicht mehr geschrieben werden kann. Auch mutet es komisch an, dass es zwei Ordner je für normale und für SSL-Inhalte gibt.

  • Keiner ne Idee?


    Hab nun auch folgende Einstellungen in "Plesk" vergenommen


    das habe ich umgegeändert


    Code
    open_basedir : {DOCROOT}/:/tmp/


    Code
    open_basedir : standart


    Klappt aber immer noch nicht.


    Nun bekomme ich diese Meldung


  • Schalte "open_basedir" einfach komplett aus, wenn es eh dein eigener Server ist. bei einem richtig konfiguriertem System sollte das zu keinen Sicherheitsbeeinträchtigungen führen.